from Civil to Inventor

The Autodesk enthusiast exile

Vault – Renaming Computer hazard

Ok, I blew it.  I recently had a fight with my domain server, and lost.  I ended up renaming my computer to work around it.  It’s never been a problem in the past.  Well, at least I didn’t realize it was.

ADMS is getting its content from an SQL server on a site.  That site is my computer, and when renamed, it was lost.  My entire ADMS and Vault was gone for all applications.

Autodesk had this to say about the errors

Issue

During the installation of Vault or Productstream Server (ADMS), you received the following pre-check error message:

The SQL Server instance you have selected is not enabled with Autodesk Productstream Replicator. To enable it, upgrade site '<computername>'. Contact your reseller for Autodesk Producstream Replicator.

Solution

This error is the result of renaming the computer or adding it to a domain while the previous version of ADMS was installed even though replication has never been enabled on this particular computer.

This can be resolved by uninstalling SQL 2005, using Add or Remove Programs (Windows), and then reinstalling it either manually or automatically using the Vault/Productstream Server installation.

Alternatively, you can run the ADMS Console in command line mode and use the -OSiteRename switch. For detailed instructions, refer to the ADMS Console Help menu (available by pressing the F1 function key).

oSiteRename

 

Continue reading

Advertisements

October 26, 2009 Posted by | 2010, Content Center, Inventor, Vault | , , , , , , , | Leave a comment

Civil 3D – FileDia Switch

image A buddy of mine took 2 subscriptions of Civil 3D home, while brooding over the need to reinstall his Civil application.  2009 or upgrade…. The rest of his project team are on 2009.

It appears as though the whole platform was fouled, because every time he tried to open the non-default drawing, Civil 3D would crash.  I was neck deep in an overdue project, so he went on his way.

This morning he reported to me that before wiping everything, he set his FileDia switch back to 1.  That’s the switch that initiates a dialog for file operation such as Open, Save, etc.  Without the switch, you just get command line options.

I like command line, but not that much…

Lo and behold, everything perked right up.  He was able to recover his drawings, and open anything from Civil, inside or out.

The moral to this story is before you reinstall due to crashing while opening a DWG, try checking your FileDia switch first.  Just type “filedia” at the command line, and set it to1.

October 5, 2009 Posted by | 2009, 2010, AutoCAD Civil 3D, Autodesk, Bug Report | , , , , , , | Leave a comment

Civil 3D – Hatch is wonked in VP

A buddy of mine cornered me about a problem he was having with his hatching.  It was wacked out in 1 viewport, but not the others.  By now there is enough circulation on the hatch origin issue that everyone knows about it.  When I mentioned it to him as a possible resolution, he said I must think he’s an idiot.

image

The answer was the Associative Property in the Hatch entity does not get along with the DView Twist angle.  Getting rid of the Associative property will calm the hatch down, as well as losing the Twist angle in the view.

If I run into a better way care for this, I’ll repost the fix

September 21, 2009 Posted by | 2010, AutoCAD Civil 3D | , , , , , , , , | Leave a comment

Civil 3D – Point Label block issue resolved

Civil 3D 2010 Update 1 cleared up the Point Label style block issue that had plagued many of us.  Kind of a relief, I have been hesitant to edit ANY Label Styles, since being tortured by the problem.  Just he knee jerk reaction to being pounded by the software.  All is well……I still crash, just not at that time.

September 7, 2009 Posted by | 2010, AutoCAD Civil 3D, Points | , , , , , , , | Leave a comment

Autodesk – DWG Launcher wigged out fix

7/8/2009

Please remember we have moved to http://johnevansdesign.net Come visit us there.

This has been a pain in numerous people’s sides for a long time.  One day you love it and the next day you hate it. 

The DWG Launcher

This gizmo is the thing that loads the drawings from remote requests, based on the registered DWG extension. AcLauncher.exe

Since Autodesk is trying to spread it’s trademarked use of DWG to numerous platforms, it needs some flexible way to allow users to open the DWG easily through explorer and other applications. 

How this works

When the OS sees a DWG file request sent, it uses the DWG registered app to open it with. In this case it is the DWG Launcher. The application uses registry entries to figure out which version of what application to use.  It is fairly simple, except there is nothing evident about it, and it gets fouled up. 

The registry settings governing this work something like a flow chart:

  1. Windows initiates default dwg app ->DWG Launcher
  2. Launcher reads shell DWG default Application –> AutoCAD
  3. Launcher goes to AutoCAD and reads launch instruction –> AutoCAD r18 exe path
  4. Launcher executes launch statement with requested dwg file

image

Most users will never have a problem with this since they only use 1 type of DWG application.  Actually, most users of differing DWG apps never have a problem. 

Continue reading

July 6, 2009 Posted by | AutoCAD Civil 3D, Inventor | , , , , , , , , , , | 5 Comments

Civil 3D – 2010 Point Label style BUG REPORT

I logged a Bug Report on Civil3D.com, and you can check it out HERE.

Autodesk Welcome Screen

I wanted to thank James Wedding and the staff at EE for putting up with me, and always being willing to assist.  I always know I’ll get some relief when I call.

I want to thank my VAR, Applied Technologies Group, for some outstanding dedication and support.  The entire team was at a remote function.  I called John Sayre who was driving in a hail storm at the time.  He insisted on getting all the details and reassured me, when most would have backed out for obvious reasons. The bug confirmation came within 10 minutes, and the support case was already logged in to Autodesk by the time I got the message. Rob, you better hang on to that guy, he means business.

Thank you Dana, for always trying to help.

June 15, 2009 Posted by | 2010, Bug Report, Points | , , , , , , , , | 1 Comment

Civil 3D – Create Point in Gap Crash

6/12/2009

Life without strife would be boring.  It’s the occasional issues that give the good times meaning.  Civil 3 is an example of this reality.

…Its kind of like playing ball with your kids before cleaning up after the dog.  It can be really enjoyable….if you are quick footed and observant.

Point Error

This instance occurred while trying to create a point in the numbering gap left by one of my oversights.

image

The result was not friendly.  As soon as I picked the location for the point placement, Civil proceeded to smack me about, and left me on the Vista desktop.

I have not had the heart to repeat this process in multiple situations, but even if this does not happen every time, I suspect it will get you eventually.

June 12, 2009 Posted by | 2010, AutoCAD Civil 3D, Points | , , , , , , | Leave a comment

Civil 3D – Parcel segment bug again

This is an oldie but a goodie.

I get this about once per year, when I have to do some survey drafting. The last time it occurred on 2007 and I had some seriously wigged out geometry. No one could say why (not the big dogs either).

It happened again, and with brutally simple geometry; no overlapping segments.

The Arc length is good, but notice the Chord length in the label.  

image

image

In the Parcel Geometry Vista the chord information is correct, but using a report, the Chord is erroneous, like the label.

image

The solution is to kill the bloody curve and recreate it.  This is rarely a solution when you have complex parceling.

I am hoping someone will have a better answer or solution that we have already heard. If you come up with something, please post it.

March 15, 2009 Posted by | 2009, Parcels | , , , , , , , | Leave a comment

Error 1606 on Install

Civil 3d.com just released an old article of mine.  Check it out. 

It’s an old topic, but it hit me at a new angle, and is not on the Autodesk FAQ.

Install error 1606 Local Admin rights on Civil3d.com

January 27, 2009 Posted by | 2009, AutoCAD Civil 3D | , , , , , , | Leave a comment