from Civil to Inventor

The Autodesk enthusiast exile

Civil 3D – 2010 Pipe Network Label BUG

We’ve moved. Join us and get these articles and more tips and reviews at Design and Motion

 

NOTE: I have revisited this issue and article 4 times over now.  I am rewriting this…again…, but the images are old because I don’t have time to cut new ones.  I hope the article is still understandable.

I needed a fast certificate of completion letter, and the drawing to go with it.  I’ll just throw down some pipes here in 2010; it’s simple, no need to go to 2009. A good job to start getting a feel for this part of the new version.

I thought I would put down some simple structures, labeled automatically, edit the network, and spend the bulk of time messing with the profile (at least I hoped).  My styles are all formatted, and all work smoothly.

Things did not go as planned.  The profile was a lost cause.  Perhaps we’ll discuss that later.

Pipe Network Labels

image

I laid down this arrangement from my (imported 2009 template) Network Parts List. Notice the disgusting mismatched labeling on the pipes and structures.  The blue, while not labeled correctly, is formatted to what I thought I’d get by default.  The Red is useless.  You have to manually change the description.

The problem is the descriptions.  We needed a fast generic label style, and decided to mod our parts list to not only contain all the material data, etc. but to change the names to something simple like, 24” RCP.  This way when we needed no pipe data, and fast labels, we’ll just take the description of the pipe, which is transferred from the Network Parts List Pipe Name.  It’s worked well for years…. Until today.

I thought 2010 decided not to like our 2009 Parts List.  This was not completely accurate.

image 

The image above depicts the route the description labels pass through.  The blue is the properly operating path, the red is the fouled path, and the green is operating as expected.

Must be Catalog Regen

You all remember that, right. In 2009, we had a disjoin between the Parts List and the Parts Catalog.  We used to be able to do a Catalog Regen, but that does not seem to get it.

Must be bad parts list

So we created a new list family, and added an 18” to it.

image

Created a pipe run. It is still conveying the Category name.

New Parts List and New Pipe and Pipe Label Styles

I created a new Parts List, a new Structure and Label Style, and a new Pipe and Label style.  I thought this was the thing.  Nope.  (I just went and did this in a new blank OEM template drawing as well…the same result!)

The Old Swap Part Trick

What we used to do is swap the parts.  After making all new stuff, I realized that you could swap the the same thing you already have. 

Upon the part swap, the information from the parts list is re-read.  The good descriptions from the parts is finally handed down.  Until then, even though you are using new networks, the parts list can’t hand out the part name so it hands out the category name. 

So we swap the part; not to another part, but to the same part it already is.

image

Now the thing updates the Network Part Description properly.

Conclusion and revisit notes

It seems that 2010 is not prejudiced.  It just doesn’t like anything.

I think this is code, not disjoin.  I think the 2010 code formats the new network parts with the category name as the description.  Then when the part is swapped, the item name comes down with the part name as the description.

I searched the command settings as well, but found nothing to suggest it’s not in the code.

Advertisements

June 19, 2009 - Posted by | 2010, AutoCAD Civil 3D, Labels, Pipes | , , , , , , , ,

3 Comments »

  1. While this may not help you in the short term with Civil 2010, I wanted to give you some news related to the part description\label issue. For 2011, we will be including a new feature setting for Pipes that allows you to either inherit the part size name from the parts list as the part description for newly created parts (pre-2010 behavior), or you can allow the description of new parts to be the part family name (2010 behavior). This new feature setting will be described in our technical documents for the next release.

    Comment by Tim Burnham | December 14, 2009 | Reply

    • Thanks Tim for the News. I look forward to some options in his area.

      Comment by John Evans | December 16, 2009 | Reply

  2. wondering about note labels… to use or not to use… the reference labels seem useful… the text notes seem broken… ie copying them from one drawing to another the data from the note is gone… and replaced by the template.. ie it just says “Note”… your thoughts on this? thanks…

    Comment by John | August 2, 2010 | Reply


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: